股价大于20日均线选股,通达信均线公式源码

Q1:求助 通达信 选股公式编写; 要求:当前股价 大于 小于 20日均线的5%--选入

a1:=c<ma(c,20)*0.95;
a2:=c>ma(c,20)*1.05;
xg:a1 or a2;

Q2:求通达信10日均线大于20日均线,并且股价回调最低价不跌破20日均线的选股公式,

MA10:=MA(CLOSE,10);
MA20:=MA(CLOSE,20);
ETZ:=MA10>MA20 AND LOW>MA20;
ETZ0:=EVERY(ETZ,5);{参数为5,表示近5日;改为30,表示近30日}
{但是回调这个概念没有加入,看个人怎么界定回调}

Q3:通达信大于20日均线涨停选股公式,不要停牌股也选进去

您的描述可理解为:最近20日振幅大于10%,目前股价回调中,正向20日线靠拢。把这样的股票选出来。
公式如下(我又细化了一下):
ar1:=(hhv(h,20)-llv(l,20))*100/llv(l,20)>10;
ar02:=ma(c,5)
ma(c,20),3)>0;
ar4:=c>ma(c,20);
xg:ar1
and
ar2
and
ar3
and
ar4;
祝您投资顺利!

Q4:10天均线大于20日均线 且小于10天的选股公式

你描述的意思是十天内发生过,十日均线金叉二十日均线,吗
如果是这样选股结果可能会非常多
如果你是这个意思的话
代码如下
MA10:=MA(C,10);
MA20:=MA(C,20);
XG:COUNT(CROSS(MA10,MA20),10)=1&&MA10>MA20;

Q5:通达信五日均线金叉10日均线的选股公式这么编写,谢谢!

CROSS(MA(C,5),MA(C,10));

Q6:求高人通达信的,60分钟K线图显示5日均线指标,万分感激。

你可以试试在60分钟k线图界面参考20均线,差不多相当于日线中的5日均线。因为一天是4小时,5天则相当于20小时,应该很近似,可以直接替代参考;
30分钟K线图略微麻烦一点,你可以修改一下某条均线的参数,将它改为40均线则可,含义也与上面一样,都是变通一下来替代5日均线。
祝顺利!